Fri, 07 Oct 2022 09:16:40 UTC

Information for build freeipa-2.1.4-5.fc16

ID296804
Package Namefreeipa
Version2.1.4
Release5.fc16
Epoch
SummaryThe Identity, Policy and Audit system
DescriptionIPA is an integrated solution to provide centrally managed Identity (machine, user, virtual machines, groups, authentication credentials), Policy (configuration settings, access control information) and Audit (events, logs, analysis thereof).
Built byabbra
State complete
Volume fedora_koji_archive00
StartedWed, 01 Feb 2012 20:31:47 UTC
CompletedWed, 01 Feb 2012 20:35:38 UTC
Taskbuild (f16-candidate, /freeipa:29ff9b554f1f5caf87c97208fc270b6639269ec7)
Tags
f16-updates
RPMs
src
freeipa-2.1.4-5.fc16.src.rpm (info) (download)
i686
freeipa-admintools-2.1.4-5.fc16.i686.rpm (info) (download)
freeipa-client-2.1.4-5.fc16.i686.rpm (info) (download)
freeipa-python-2.1.4-5.fc16.i686.rpm (info) (download)
freeipa-server-2.1.4-5.fc16.i686.rpm (info) (download)
freeipa-server-selinux-2.1.4-5.fc16.i686.rpm (info) (download)
freeipa-debuginfo-2.1.4-5.fc16.i686.rpm (info) (download)
x86_64
freeipa-admintools-2.1.4-5.fc16.x86_64.rpm (info) (download)
freeipa-client-2.1.4-5.fc16.x86_64.rpm (info) (download)
freeipa-python-2.1.4-5.fc16.x86_64.rpm (info) (download)
freeipa-server-2.1.4-5.fc16.x86_64.rpm (info) (download)
freeipa-server-selinux-2.1.4-5.fc16.x86_64.rpm (info) (download)
freeipa-debuginfo-2.1.4-5.fc16.x86_64.rpm (info) (download)
Logs
i686
build.log
root.log
state.log
x86_64
build.log
root.log
state.log
Changelog * Wed Feb 01 2012 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.4-5 - Force to use 389-ds 1.2.10-0.8.a7 or above - Improve upgrade script to handle systemd 389-ds change - Fix freeipa to work with python-ldap 2.4.6 * Wed Jan 11 2012 Martin Kosek <mkosek@redhat.com> - 2.1.4-4 - Fix ipa-replica-install crashes - Fix ipa-server-install and ipa-dns-install logging - Set minimum version of pki-ca to 9.0.17 to fix sslget problem caused by FEDORA-2011-17400 update (#771357) * Wed Dec 21 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.4-3 - Allow Web-based migration to work with tightened SE Linux policy (#769440) - Rebuild slapi plugins against re-enterant version of libldap * Sun Dec 11 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.4-2 - Allow longer dirsrv startup with systemd: - IPAdmin class will wait until dirsrv instance is available up to 10 seconds - Helps with restarts during upgrade for ipa-ldap-updater - Fix pylint warnings from F16 and Rawhide * Tue Dec 06 2011 Rob Crittenden <rcritten@redhat.com> - 2.1.4-1 - Update to upstream 2.1.4 (CVE-2011-3636) * Mon Dec 05 2011 Rob Crittenden <rcritten@redhat.com> - 2.1.3-8 - Update SELinux policy to allow ipa_kpasswd to connect ldap and read /dev/urandom. (#759679) * Wed Nov 30 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-7 - Fix typo in install of freeipa-systemd-upgrade script * Wed Nov 30 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-6 - Introduce upgrade script to recover existing configuration after systemd migration as user has no means to recover FreeIPA from systemd migration - Upgrade script: - recovers symlinks in Dogtag instance install - recovers systemd configuration for FreeIPA's directory server instances - recovers freeipa.service - migrates directory server and KDC configs to use proper keytabs for systemd services * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.3-5 - Rebuilt for glibc bug#747377 * Wed Oct 19 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-4 - clean up spec - Depend on sssd >= 1.6.2 for better user experience * Tue Oct 18 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-3 - Fix Fedora package changelog after merging systemd changes * Tue Oct 18 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-2 - Fix postin scriplet for F-15/F-16 * Tue Oct 18 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.3-1 - 2.1.3 * Mon Oct 17 2011 Alexander Bokovoy <abokovoy@redhat.com> - 2.1.2-1 - Default to systemd for Fedora 16 and onwards * Tue Aug 16 2011 Rob Crittenden <rcritten@redhat.com> - 2.1.0-1 - Update to upstream 2.1.0 * Fri May 06 2011 Simo Sorce <ssorce@redhat.com> - 2.0.1-2 - Fix bug #702633 * Mon May 02 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.1-1 - Update minimum selinux-policy to 3.9.16-18 - Update minimum pki-ca and pki-selinux to 9.0.7 - Update minimum 389-ds-base to 1.2.8.0-1 - Update to upstream 2.0.1 * Thu Mar 24 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-1 - Update to upstream GA release - Automatically apply updates when the package is upgraded * Fri Feb 25 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.4.rc2 - Update to upstream freeipa-2.0.0.rc2 - Set minimum version of python-nss to 0.11 to make sure IPv6 support is in - Set minimum version of sssd to 1.5.1 - Patch to include SuiteSpotGroup when setting up 389-ds instances - Move a lot of BuildRequires so this will build with ONLY_CLIENT enabled * Tue Feb 15 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.3.rc1 - Set the N-V-R so rc1 is an update to beta2. * Mon Feb 14 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.1.rc1 - Set minimum version of sssd to 1.5.1 - Update to upstream freeipa-2.0.0.rc1 - Move server-only binaries from admintools subpackage to server * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-0.2.beta2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild * Thu Feb 03 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.1.beta2 - Set min version of 389-ds-base to 1.2.8 - Set min version of mod_nss 1.0.8-10 - Set min version of selinux-policy to 3.9.7-27 - Add dogtag themes to Requires - Update to upstream freeipa-2.0.0.pre2 * Thu Jan 27 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.2.beta.git80e87e7 - Remove unnecessary moving of v1 CA serial number file in post script - Add Obsoletes for server-selinxu subpackage - Using git snapshot 442d6ad30ce1156914e6245aa7502499e50ec0da * Wed Jan 26 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.1.beta.git80e87e7 - Prepare spec file for release - Using git snapshot 80e87e75bd6ab56e3e20c49ece55bd4d52f1a503 * Tue Jan 25 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-41 - Re-arrange doc and defattr to clean up rpmlint warnings - Remove conditionals on older releases - Move some man pages into admintools subpackage - Remove some explicit Requires in client that aren't needed - Consistent use of buildroot vs RPM_BUILD_ROOT * Wed Jan 19 2011 Adam Young <ayoung@redhat.com> - 1.99-40 - Moved directory install/static to install/ui * Thu Jan 13 2011 Simo Sorce <ssorce@redhat.com> - 1.99-39 - Remove dependency on nss_ldap/nss-pam-ldapd - The official client is sssd and that's what we use by default. * Thu Jan 13 2011 Simo Sorce <ssorce@redhat.com> - 1.99-38 - Remove radius subpackages * Thu Jan 13 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-37 - Set minimum pki-ca and pki-silent versions to 9.0.0 * Wed Jan 12 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-36 - Drop BuildRequires on mozldap-devel * Mon Dec 13 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-35 - Add Requires on krb5-pkinit-openssl * Fri Dec 10 2010 Jr Aquino <jr.aquino@citrix.com> - 1.99-34 - Add ipa-host-net-manage script * Tue Dec 07 2010 Simo Sorce <ssorce@redhat.com> - 1.99-33 - Add ipa init script * Fri Nov 19 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-32 - Set minimum level of 389-ds-base to 1.2.7 for enhanced memberof plugin * Wed Nov 03 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-31 - remove ipa-fix-CVE-2008-3274 * Wed Oct 06 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-30 - Remove duplicate %files entries on share/ipa/static - Add python default encoding shared library * Mon Sep 20 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-29 - Drop requires on python-configobj (not used any more) - Drop ipa-ldap-updater message, upgrades are done differently now * Wed Sep 08 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-28 - Drop conflicts on mod_nss - Require nss-pam-ldapd on F-14 or higher instead of nss_ldap (#606847) - Drop a slew of conditionals on older Fedora releases (< 12) - Add a few conditionals against RHEL 6 - Add Requires of nss-tools on ipa-client * Fri Aug 13 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-27 - Set minimum version of certmonger to 0.26 (to pck up #621670) - Set minimum version of pki-silent to 1.3.4 (adds -key_algorithm) - Set minimum version of pki-ca to 1.3.6 - Set minimum version of sssd to 1.2.1 * Tue Aug 10 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-26 - Add BuildRequires for authconfig * Mon Jul 19 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-25 - Bump up minimum version of python-nss to pick up nss_is_initialize() API * Thu Jun 24 2010 Adam Young <ayoung@redhat.com> - 1.99-24 - Removed python-asset based webui * Thu Jun 24 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-23 - Change Requires from fedora-ds-base to 389-ds-base - Set minimum level of 389-ds-base to 1.2.6 for the replication version plugin. * Tue Jun 01 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-22 - Drop Requires of python-krbV on ipa-client * Mon May 17 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-21 - Load ipa_dogtag.pp in post install * Mon Apr 26 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-20 - Set minimum level of sssd to 1.1.1 to pull in required hbac fixes. * Thu Mar 04 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-19 - No need to create /var/log/ipa_error.log since we aren't using TurboGears any more. * Mon Mar 01 2010 Jason Gerard DeRose <jderose@redhat.com> - 1.99-18 - Fixed share/ipa/wsgi.py so .pyc, .pyo files are included * Wed Feb 24 2010 Jason Gerard DeRose <jderose@redhat.com> - 1.99-17 - Added Require mod_wsgi, added share/ipa/wsgi.py * Thu Feb 11 2010 Jason Gerard DeRose <jderose@redhat.com> - 1.99-16 - Require python-wehjit >= 0.2.2 * Wed Feb 03 2010 Rob Crittenden <rcritten@redhat.com> - 1.99-15 - Add sssd and certmonger as a Requires on ipa-client * Wed Jan 27 2010 Jason Gerard DeRose <jderose@redhat.com> - 1.99-14 - Require python-wehjit >= 0.2.0 * Fri Dec 04 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-13 - Add ipa-rmkeytab tool * Tue Dec 01 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-12 - Set minimum of python-pyasn1 to 0.0.9a so we have support for the ASN.1 Any type * Wed Nov 25 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-11 - Remove v1-style /etc/ipa/ipa.conf, replacing with /etc/ipa/default.conf * Fri Nov 13 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-10 - Add bash completion script and own /etc/bash_completion.d in case it doesn't already exist * Tue Nov 03 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-9 - Remove ipa_webgui, its functions rolled into ipa_httpd * Mon Oct 12 2009 Jason Gerard DeRose <jderose@redhat.com> - 1.99-8 - Removed python-cherrypy from BuildRequires and Requires - Added Requires python-assets, python-wehjit * Mon Aug 24 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-7 - Added httpd SELinux policy so CRLs can be read * Thu May 21 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-6 - Move ipalib to ipa-python subpackage - Bump minimum version of slapi-nis to 0.15 * Wed May 06 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-5 - Set 0.14 as minimum version for slapi-nis * Wed Apr 22 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-4 - Add Requires: python-nss to ipa-python sub-package * Thu Mar 05 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-3 - Remove the IPA DNA plugin, use the DS one * Wed Mar 04 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-2 - Build radius separately - Fix a few minor issues * Tue Feb 03 2009 Rob Crittenden <rcritten@redhat.com> - 1.99-1 - Replace TurboGears requirement with python-cherrypy * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.1-3 - rebuild with new openssl * Fri Dec 19 2008 Dan Walsh <dwalsh@redhat.com> - 1.2.1-2 - Fix SELinux code * Mon Dec 15 2008 Simo Sorce <ssorce@redhat.com> - 1.2.1-1 - Fix breakage caused by python-kerberos update to 1.1 * Fri Dec 05 2008 Simo Sorce <ssorce@redhat.com> - 1.2.1-0 - New upstream release 1.2.1 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-4 - Rebuild for Python 2.6 * Fri Nov 14 2008 Simo Sorce <ssorce@redhat.com> - 1.2.0-3 - Respin after the tarball has been re-released upstream New hash is 506c9c92dcaf9f227cba5030e999f177 * Thu Nov 13 2008 Simo Sorce <ssorce@redhat.com> - 1.2.0-2 - Conditionally restart also dirsrv and httpd when upgrading * Wed Oct 29 2008 Rob Crittenden <rcritten@redhat.com> - 1.2.0-1 - Update to upstream version 1.2.0 - Set fedora-ds-base minimum version to 1.1.3 for winsync header - Set the minimum version for SELinux policy - Remove references to Fedora 7 * Wed Jul 23 2008 Simo Sorce <ssorce@redhat.com> - 1.1.0-3 - Fix for CVE-2008-3274 - Fix segfault in ipa-kpasswd in case getifaddrs returns a NULL interface - Add fix for bug #453185 - Rebuild against openldap libraries, mozldap ones do not work properly - TurboGears is currently broken in rawhide. Added patch to not build the UI locales and removed them from the ipa-server files section. * Wed Jun 18 2008 Rob Crittenden <rcritten@redhat.com> - 1.1.0-2 - Add call to /usr/sbin/upgradeconfig to post install * Wed Jun 11 2008 Rob Crittenden <rcritten@redhat.com> - 1.1.0-1 - Update to upstream version 1.1.0 - Patch for indexing memberof attribute - Patch for indexing uidnumber and gidnumber - Patch to change DNA default values for replicas - Patch to fix uninitialized variable in ipa-getkeytab * Fri May 16 2008 Rob Crittenden <rcritten@redhat.com> - 1.0.0-5 - Set fedora-ds-base minimum version to 1.1.0.1-4 and mod_nss minimum version to 1.0.7-4 so we pick up the NSS fixes. - Add selinux-policy-base(post) to Requires (446496) * Tue Apr 29 2008 Rob Crittenden <rcritten@redhat.com> - 1.0.0-4 - Add missing entry for /var/cache/ipa/kpasswd (444624) - Added patch to fix permissions problems with the Apache NSS database. - Added patch to fix problem with DNS querying where the query could be returned as the answer. - Fix spec error where patch1 was in the wrong section * Fri Apr 25 2008 Rob Crittenden <rcritten@redhat.com> - 1.0.0-3 - Added patch to fix problem reported by ldapmodify * Fri Apr 25 2008 Rob Crittenden <rcritten@redhat.com> - 1.0.0-2 - Fix Requires for krb5-server that was missing for Fedora versions > 9 - Remove quotes around test for fedora version to package egg-info * Fri Apr 18 2008 Rob Crittenden <rcritten@redhat.com> - 1.0.0-1 - Update to upstream version 1.0.0 * Tue Mar 18 2008 Rob Crittenden <rcritten@redhat.com> 0.99-12 - Pull upstream changelog 722 - Add Conflicts mod_ssl (435360) * Fri Feb 29 2008 Rob Crittenden <rcritten@redhat.com> 0.99-11 - Pull upstream changelog 698 - Fix ownership of /var/log/ipa_error.log during install (435119) - Add pwpolicy command and man page * Thu Feb 21 2008 Rob Crittenden <rcritten@redhat.com> 0.99-10 - Pull upstream changelog 678 - Add new subpackage, ipa-server-selinux - Add Requires: authconfig to ipa-python (bz #433747) - Package i18n files * Mon Feb 18 2008 Rob Crittenden <rcritten@redhat.com> 0.99-9 - Pull upstream changelog 641 - Require minimum version of krb5-server on F-7 and F-8 - Package some new files * Thu Jan 31 2008 Rob Crittenden <rcritten@redhat.com> 0.99-8 - Marked with wrong license. IPA is GPLv2. * Tue Jan 29 2008 Rob Crittenden <rcritten@redhat.com> 0.99-7 - Ensure that /etc/ipa exists before moving user-modifiable html files there - Put html files into /etc/ipa/html instead of /etc/ipa * Tue Jan 29 2008 Rob Crittenden <rcritten@redhat.com> 0.99-6 - Pull upstream changelog 608 which renamed several files * Thu Jan 24 2008 Rob Crittenden <rcritten@redhat.com> 0.99-5 - package the sessions dir /var/cache/ipa/sessions - Pull upstream changelog 597 * Thu Jan 24 2008 Rob Crittenden <rcritten@redhat.com> 0.99-4 - Updated upstream pull (596) to fix bug in ipa_webgui that was causing the UI to not start. * Thu Jan 24 2008 Rob Crittenden <rcritten@redhat.com> 0.99-3 - Included LICENSE and README in all packages for documentation - Move user-modifiable content to /etc/ipa and linked back to /usr/share/ipa/html - Changed some references to /usr to the {_usr} macro and /etc to {_sysconfdir} - Added popt-devel to BuildRequires for Fedora 8 and higher and popt for Fedora 7 - Package the egg-info for Fedora 9 and higher for ipa-python * Tue Jan 22 2008 Rob Crittenden <rcritten@redhat.com> 0.99-2 - Added auto* BuildRequires * Mon Jan 21 2008 Rob Crittenden <rcritten@redhat.com> 0.99-1 - Unified spec file * Thu Jan 17 2008 Rob Crittenden <rcritten@redhat.com> - 0.6.0-2 - Fixed License in specfile - Include files from /usr/lib/python*/site-packages/ipaserver * Fri Dec 21 2007 Karl MacMillan <kmacmill@redhat.com> - 0.6.0-1 - Version bump for release * Wed Nov 21 2007 Karl MacMillan <kmacmill@mentalrootkit.com> - 0.5.0-1 - Preverse mode on ipa-keytab-util - Version bump for relase and rpm name change * Thu Nov 15 2007 Rob Crittenden <rcritten@redhat.com> - 0.4.1-2 - Broke invididual Requires and BuildRequires onto separate lines and reordered them - Added python-tgexpandingformwidget as a dependency - Require at least fedora-ds-base 1.1 * Thu Nov 01 2007 Karl MacMillan <kmacmill@redhat.com> - 0.4.1-1 - Version bump for release * Wed Oct 31 2007 Karl MacMillan <kmacmill@redhat.com> - 0.4.0-6 - Add dep for freeipa-admintools and acl * Wed Oct 24 2007 Rob Crittenden <rcritten@redhat.com> - 0.4.0-5 - Add dependency for python-krbV * Fri Oct 19 2007 Rob Crittenden <rcritten@redhat.com> - 0.4.0-4 - Require mod_nss-1.0.7-2 for mod_proxy fixes * Thu Oct 18 2007 Karl MacMillan <kmacmill@redhat.com> - 0.4.0-3 - Convert to autotools-based build * Tue Sep 25 2007 Karl MacMillan <kmacmill@redhat.com> - 0.4.0-2 * Fri Sep 7 2007 Karl MacMillan <kmacmill@redhat.com> - 0.3.0-1 - Added support for libipa-dna-plugin * Fri Aug 10 2007 Karl MacMillan <kmacmill@redhat.com> - 0.2.0-1 - Added support for ipa_kpasswd and ipa_pwd_extop * Sun Aug 05 2007 Rob Crittenden <rcritten@redhat.com> - 0.1.0-3 - Abstracted client class to work directly or over RPC * Wed Aug 01 2007 Rob Crittenden <rcritten@redhat.com> - 0.1.0-2 - Add mod_auth_kerb and cyrus-sasl-gssapi to Requires - Remove references to admin server in ipa-server-setupssl - Generate a client certificate for the XML-RPC server to connect to LDAP with - Create a keytab for Apache - Create an ldif with a test user - Provide a certmap.conf for doing SSL client authentication * Fri Jul 27 2007 Karl MacMillan <kmacmill@redhat.com> - 0.1.0-1 - Initial rpm version