Tue, 18 Jan 2022 07:23:01 UTC

Information for RPM eclipse-jdt-1:4.15-5.module_f32+8555+6b76193d.noarch.rpm

ID21081575
Nameeclipse-jdt
Version4.15
Release5.module_f32+8555+6b76193d
Epoch1
Archnoarch
SummaryEclipse Java Development Tools
DescriptionEclipse Java Development Tools. This package is required to use Eclipse for developing software written in the Java programming language.
Build Time2020-04-02 23:26:40 GMT
Size32,926,813
e4610947abeed252d4a20aed5c7d540f
LicenseEPL-2.0
Buildrootmodule-eclipse-latest-3220200402225102-7114797f-build-20108063-1424462
Provides
eclipse = 1:4.15-5.module_f32+8555+6b76193d
eclipse-jdt = 1:4.15-5.module_f32+8555+6b76193d
metainfo()
metainfo(eclipse-jdt.metainfo.xml)
mvn(org.eclipse.ant:org.eclipse.ant.launching) = 1.2.800.SNAPSHOT
mvn(org.eclipse.ant:org.eclipse.ant.ui) = 3.7.700.SNAPSHOT
mvn(org.eclipse.jdt.feature:org.eclipse.jdt) = 3.18.300.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt) = 3.18.300.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.annotation) = 2.2.400.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.core) = 3.6.550.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.pluggable.core) = 1.2.400.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.ui) = 3.6.300.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.apt) = 1.3.900.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.tool) = 1.2.800.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core) = 3.21.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core.formatterapp) = 1.0.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core.manipulation) = 1.13.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug) = 3.15.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug.ui) = 3.10.600.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.doc.user) = 3.15.600.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit) = 3.11.700.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.core) = 3.10.600.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.runtime) = 3.5.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit4.runtime) = 1.1.1200.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit5.runtime) = 1.0.800.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.launching) = 3.17.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.ui) = 3.21.0.SNAPSHOT
osgi(org.eclipse.ant.launching) = 1.2.800.v20200316.1200
osgi(org.eclipse.ant.ui) = 3.7.700.v20200316.1200
osgi(org.eclipse.jdt) = 3.18.300.v20200316.1200
osgi(org.eclipse.jdt.annotation) = 2.2.400.v20200316.1200
osgi(org.eclipse.jdt.apt.core) = 3.6.550.v20200316.1200
osgi(org.eclipse.jdt.apt.pluggable.core) = 1.2.400.v20200316.1200
osgi(org.eclipse.jdt.apt.ui) = 3.6.300.v20200316.1200
osgi(org.eclipse.jdt.compiler.apt) = 1.3.900.v20200316.1200
osgi(org.eclipse.jdt.compiler.tool) = 1.2.800.v20200316.1200
osgi(org.eclipse.jdt.core) = 3.21.0.v20200316.1200
osgi(org.eclipse.jdt.core.formatterapp) = 1.0.0.v20200316.1200
osgi(org.eclipse.jdt.core.manipulation) = 1.13.100.v20200316.1200
osgi(org.eclipse.jdt.debug) = 3.15.0.v20200316.1200
osgi(org.eclipse.jdt.debug.ui) = 3.10.600.v20200316.1200
osgi(org.eclipse.jdt.doc.user) = 3.15.600.v20200316.1200
osgi(org.eclipse.jdt.junit) = 3.11.700.v20200316.1200
osgi(org.eclipse.jdt.junit.core) = 3.10.600.v20200316.1200
osgi(org.eclipse.jdt.junit.runtime) = 3.5.100.v20200316.1200
osgi(org.eclipse.jdt.junit4.runtime) = 1.1.1200.v20200316.1200
osgi(org.eclipse.jdt.junit5.runtime) = 1.0.800.v20200316.1200
osgi(org.eclipse.jdt.launching) = 3.17.0.v20200316.1200
osgi(org.eclipse.jdt.ui) = 3.21.0.v20200316.1200
Obsoletes
eclipse-recommenders <= 2.5.4-5
Conflicts No Conflicts
Requires
eclipse-platform = 1:4.15-5.module_f32+8555+6b76193d
java-headless >= 1:1.8
javapackages-filesystem
junit >= 4.12
junit5 >= 5.4.0
osgi(org.apiguardian)
osgi(org.hamcrest.core)
osgi(org.junit)
osgi(org.junit.jupiter.api)
osgi(org.junit.jupiter.engine)
osgi(org.junit.jupiter.migrationsupport)
osgi(org.junit.jupiter.params)
osgi(org.junit.platform.commons)
osgi(org.junit.platform.engine)
osgi(org.junit.platform.launcher)
osgi(org.junit.platform.runner)
osgi(org.junit.platform.suite.api)
osgi(org.junit.vintage.engine)
osgi(org.opentest4j)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
Page:
1 through 50 of 69 >>>
Name ascending sort Size
/usr/share/appdata/eclipse-jdt.metainfo.xml774
/usr/share/eclipse/droplets/eclipse-jdt0
/usr/share/eclipse/droplets/eclipse-jdt/features0
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-12000
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF0
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/MANIFEST.MF97
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/maven0
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/maven/org.eclipse.jdt.feature0
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt0
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.properties116
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.xml2,811
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/epl-2.0.html17,300
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/feature.properties10,065
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/feature.xml3,967
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.18.300.v20200316-1200/license.html9,260
/usr/share/eclipse/droplets/eclipse-jdt/fragment.info3,840
/usr/share/eclipse/droplets/eclipse-jdt/plugins0
/usr/share/eclipse/droplets/eclipse-jdt/plugins/com.univocity.parsers_2.5.5.jar56
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.apiguardian_1.0.0.jar48
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.ant.launching_1.2.800.v20200316-1200.jar154,136
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.ant.ui_3.7.700.v20200316-1200.jar1,026,409
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.annotation_2.2.400.v20200316-1200.jar20,227
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.core_3.6.550.v20200316-1200.jar371,483
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.pluggable.core_1.2.400.v20200316-1200.jar34,068
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.ui_3.6.300.v20200316-1200.jar65,767
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.compiler.apt_1.3.900.v20200316-1200.jar209,795
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.compiler.tool_1.2.800.v20200316-1200.jar184,652
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.core.formatterapp_1.0.0.v20200316-1200.jar7,875
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.core.manipulation_1.13.100.v20200316-1200.jar1,523,104
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.core_3.21.0.v20200316-1200.jar6,791,600
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug.ui_3.10.600.v20200316-1200.jar1,610,692
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-12000
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/.api_description2,352
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/.options242
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF0
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/MANIFEST.MF2,609
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/maven0
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/maven/org.eclipse.jdt0
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug0
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.properties112
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.xml1,076
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/about.html1,460
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/jdi.jar55,949
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/jdimodel.jar943,693
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/plugin.properties1,783
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.15.0.v20200316-1200/plugin.xml13,974
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.doc.user_3.15.600.v20200316-1200.jar10,312,010
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit.core_3.10.600.v20200316-1200.jar167,185
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit.runtime_3.5.100.v20200316-1200.jar49,727
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit4.runtime_1.1.1200.v20200316-1200.jar21,065
Component of
1 through 1 of 1
Buildroot descending sort Created State
module-eclipse-latest-3220200402225102-7114797f-build-20108739-1424500 2020-04-03 00:24:53 expired