Thu, 02 Dec 2021 20:14:13 UTC

Information for RPM mpi4py-mpich2-1.3-5.el6.x86_64.rpm

ID3282760
Namempi4py-mpich2
Version1.3
Release5.el6
Epoch
Archx86_64
SummaryPython bindings of MPI, MPICH2 version
DescriptionThis package is constructed on top of the MPI-1/MPI-2 specification and provides an object oriented interface which closely follows MPI-2 C++ bindings. It supports point-to-point (sends, receives) and collective (broadcasts, scatters, gathers) communications of any picklable Python object as well as optimized communications of Python object exposing the single-segment buffer interface (NumPy arrays, built-in bytes/string/array objects). This package contains mpi4py compiled against MPICH2.
Build Time2012-08-04 18:29:11 GMT
Size434,896
5df87c333f4a53c7e61d3c8ebf0e0918
LicenseBSD
Buildrootdist-6E-epel-build-1428612-231852
Provides
mpi4py-mpich2 = 1.3-5.el6
mpi4py-mpich2(x86-64) = 1.3-5.el6
mpi4py-runtime = 1.3-5.el6
python2-mpi4py-mpich2 = 1.3-5.el6
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libmpich.so.1.2()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libpython2.6.so.1.0()(64bit)
librt.so.1()(64bit)
libutil.so.1()(64bit)
mpi4py-common = 1.3-5.el6
mpich2
python(abi) = 2.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 30 of 30
Name ascending sort Size
/usr/lib64/python2.6/site-packages/mpich2/mpi4py4,096
/usr/lib64/python2.6/site-packages/mpich2/mpi4py-1.3-py2.6.egg-info3,036
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/MPE.so309,640
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/MPI.so986,592
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/__init__.py2,219
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/__init__.pyc2,431
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/__init__.pyo2,431
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/bin4,096
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/bin/python-mpi5,624
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/dl.so6,976
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include4,096
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py4,096
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/MPI.pxd3,555
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/__init__.pxd56
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/__init__.pyx56
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi.pxi37,141
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi4py.MPI.h7,512
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi4py.MPI_api.h14,710
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi4py.h280
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi4py.i2,319
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/include/mpi4py/mpi_c.pxd82
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/lib-pmpi4,096
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/lib-pmpi/libmpe.so273,224
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/lib-pmpi/libvt-hyb.so3,696
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/lib-pmpi/libvt-mpi.so3,696
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/lib-pmpi/libvt.so3,776
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/mpi.cfg157
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/rc.py2,931
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/rc.pyc2,275
/usr/lib64/python2.6/site-packages/mpich2/mpi4py/rc.pyo2,275
Component of No Buildroots